NerfUS game coordinator for the Nerf gun firing range

Dependencies:   HardwareInterface mbed-rtos mbed

Fork of NerfUS by NerfUS

Revision:
8:0498fa4f5c1f
Parent:
4:8b9f91de6cf1
Child:
12:55930acb6c96
--- a/CMakeLists.txt	Thu Feb 09 02:01:51 2017 +0000
+++ b/CMakeLists.txt	Thu Feb 09 14:24:39 2017 -0500
@@ -1,43 +1,11 @@
 cmake_minimum_required(VERSION 3.5)
-project(NerfUS)
 
-# Download and unpack googletest at configure time
-configure_file(CMakeLists.txt.in
-               googletest-download/CMakeLists.txt)
-execute_process(COMMAND ${CMAKE_COMMAND} -G "${CMAKE_GENERATOR}" .
-  WORKING_DIRECTORY ${CMAKE_BINARY_DIR}/googletest-download )
-execute_process(COMMAND ${CMAKE_COMMAND} --build .
-  WORKING_DIRECTORY ${CMAKE_BINARY_DIR}/googletest-download )
- 
-# Prevent GoogleTest from overriding our compiler/linker options
-# when building with Visual Studio
-set(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
- 
-# Add googletest directly to our build. This adds
-# the following targets: gtest, gtest_main, gmock
-# and gmock_main
-add_subdirectory(${CMAKE_BINARY_DIR}/googletest-src
-                 ${CMAKE_BINARY_DIR}/googletest-build)
- 
-# The gtest/gmock targets carry header search path
-# dependencies automatically when using CMake 2.8.11 or
-# later. Otherwise we have to add them here ourselves.
-if (CMAKE_VERSION VERSION_LESS 2.8.11)
-  include_directories("${gtest_SOURCE_DIR}/include"
-                      "${gmock_SOURCE_DIR}/include")
-endif()
- 
-# Now simply link your own targets against gtest, gmock,
-# etc. as appropriate
+include("GoogleTest.cmake")
+
 include_directories(include)
-include_directories("${gtest_SOURCE_DIR}/include")
-
-# Where Google Test's libraries can be found.
-#link_directories("./googletest-build/googlemock/gtest/libgtest.a")
 
 file(GLOB SOURCES "source/*.cpp")
 file(GLOB TEST_SOURCES "TESTS/*.cpp")
 
 add_executable(run_unit_tests ${SOURCES} ${TEST_SOURCES})
-
-target_link_libraries(run_unit_tests gtest gmock gmock_main)
+target_link_libraries(run_unit_tests gmock_main)