Report
2 years, 2 months ago.

Should NUCLEO_BLE_UART work with Nucleo F411RE board?

Hello, My setup: Nucleo F411RE with I-NUCLEO-IDB04A1 shield. The program hangs at ble.init(); Even the LED stops blinking. Should this program work with Nucleo F411RE? Thanks

Question relating to:

BLE UART example for Nucloe board and Bluetooth LE Nucleo shield.
Comment on this question

1 Answer

2 years, 2 months ago.

Hi,

Yes should work with the F411RE. Please refer to stuck on btle_init>>

For the LED, I recommend you to remove led1 from the project as there is a hardware conflict between LED1 and one of the SPI pins used to talk to the BLE device.

Regards.

Hello I'm sorry but it seems doesn't work well... I removed led1 from the script and shorted pins 11 and 31. now ST BlueNRG serial terminal is able to see the device "BlueNRG_HRM" but after few seconds....it exits with this error message: "No valid characteristics found. Wrong firmware? Please check instruction on how to setup the BlueNRG board". Of course it tryed to update firmware using java script inside CUBE package for IDB04A1 board but it's not able to do it.Updater is not able to update firmware. On my serial monitor when I run the application I see these lines: updating bleCharacteristic charHandle =17, corresponding serviceHandle= 16 /media/uploads/loarri/idb04a1_bluetooth.png I'm using F411RE and IDB04A1 board.

thanks for your help!!!! and regards Lorenzo

posted by Lorenzo Arrigoni 21 Aug 2015

To post an answer, please log in.