Renesas


Renesas Electronics Corporation (TSE: 6723), the world's number one supplier of microcontrollers, is a premier supplier of advanced semiconductor solutions including microcontrollers, SoC solutions and a broad range of analog and power devices.

Exporting to e2studio with J_Link debug

Environment

/media/uploads/RyoheiHagimoto/e2studio-jlink-component.png
You need following components:

  • GR-PEACH
  • USB micro-B cable
  • J-Link series
  • J-Link 9-pin Cortex-M Adapter or equivalent
  • Cortex 9-pin header (1.25mm pitch 2x5)

If you do not have them, goto Exporting to e2studio (CMSIS-DAP debug).

Setup

Mount Cortex 9-pin header to GR-PEACH

Mount Cortex 9-pin header to "JTAG" of GR-PEACH.
Note: 7th pin is not used (without header).

Install Windows serial driver

Install latest Windows Serial Port Driver to setup CMSIS-DAP from the link below:
https://mbed.org/handbook/Windows-serial-configuration

Install e2studio

Download e2studio 5.0.0 or lator, and install

Build of e2studio environment

Exporting to e2studio

  1. Go to mbed compiler.
  2. Right click at the program you want to export.
  3. Select "Export Program"
    /media/uploads/RyoheiHagimoto/export1.png
  4. Select "Renesas GR-PEACH" for Export Target
    Select "e2studio" for Export Toolchain
    Push "Export"
    /media/uploads/1050186/export_e2stutio_select_e2studio.png
  5. Expand zip file.

import project to e2studio

  1. Launch e2studio.
  2. Specify workspace directory. Workspace directory must be placed in the upper directory of the directory that includes .project file.
    In this document, project file is placed in C:\WorkSpace\GR-PEACH_blinky_e2studio_rz_a1h\GR-PEACH_blinky, and the workspace is placed in C:\WorkSpace\GR-PEACH_blinky_e2studio_rz_a1h.
    /media/uploads/RyoheiHagimoto/e2studio-workspace.png
  3. If Toolchain Integration dialog appared, select [GCC ARM embedded version 4.9.3.20150529] and click [Register].
    /media/uploads/RyoheiHagimoto/e2studio-toolchain.png
  4. After e2studio window opens, click [go to workbench].
    /media/uploads/RyoheiHagimoto/e2studio-top.png
  5. Select [File]menu-[import].
    /media/uploads/RyoheiHagimoto/e2studio-import01.png
  6. Select [General]-[Existing Projects into Workspace], and click [Next>]
    /media/uploads/RyoheiHagimoto/e2studio-import02.png
  7. Click [Browse].
    /media/uploads/RyoheiHagimoto/e2studio-import03.png
  8. Click [OK].
    /media/uploads/RyoheiHagimoto/e2studio-import04.png
  9. Click [Finish].
    /media/uploads/RyoheiHagimoto/e2studio-import05.png

Build Process

  1. Launch e2studio.
  2. Select the [Window] menu -> [Show View] -> [Project Explorer].
  3. Select the project to build.
  4. Click build icon. /media/uploads/RyoheiHagimoto/e2studio-build.png

  e.g.) The folder structure when making the work folder "C:\Workspase". Export project is GR-PEACH_blinky.
    C:
    +-- Workspace
        +-- GR-PEACH_blinky_e2studio_rz_a1h
            +-- .metadata
            +-- GR-PEACH_blinky
                |   .cproject
                |   .gdbinit
                |   .hgignore
                |   .project
                |   exporter.yaml
                |   GettingStarted.htm
                |   GR-PEACH_blinky OpenOCD.launch
                |   main.cpp
                |   mbed.bld
                |   SoftPWM.lib
                +-- .hg
                +-- .settings
                +-- Debug <- When clicking [Build Project], ".bin" and ".elf" file will be created here.
                +-- mbed
                +-- SoftPWM


The way to debug

  1. Connect your PC and GR-PEACH via J-Link.
  2. Turn on GR-PEACH (by connecting USB cable).
  3. Select project to debug.
  4. From menu in C/C++ perspective or DS-5 debug perspective , select [Run] [Debug Configurations...]
  5. Select [Renesas GDB Hardware Debugging]<i>
  6. Click <New> icon <ii>
  7. Confirm a new configuration of your project has been generated.<iii>
  8. Click Debugger tab.<iv>
  9. Select [J-Link ARM] of [Debug hardware]. <v>
  10. Select [...] - [RZ] - [RZ/A1] - [R7S721001] of [Target Device]. <vi>
  11. Click [Startup] tab. <vii>
  12. Check [Resume] box <viii>.
  13. Click [Apply] button. <ix>
  14. Click [Debug] button <x>.
    /media/uploads/RyoheiHagimoto/e2studio_jlink0.png
    /media/uploads/RyoheiHagimoto/e2studio_jlink1.png